f:id:t-d-0203:20180725181059p:plain

こんにちわanです。

今回新しい環境構築で早速躓いたのでログ残しておきます。

Sponsored Link - Powered by Google.

Ubuntu 18.04 に rbenv で Ruby 2.5.1 を入れる時のエラー解決策

ruby 2.4未満のものは原因はこちらです。

Ruby < 2.4 is not compatible with openssl 1.1. You need to install libssl1.0-dev.

Can’t build on Ubuntu 18.04 (bionic64) · Issue #1199 · rbenv/ruby-build · GitHub

 openssl が問題みたいなんでググったらたくさん出てきます。

Ubuntu 18.04上においてruby-buildでruby 2.3.*をインストールする – 有馬総一郎のブログ

今回は2.4以上なのにエラー!な人向け。

エラー内容は以下。

むう…。なんでだ。

rbenvから説明すると以下で導入できました。

Rubyくらいすぐ入るように作っててほしいですね。

 

Sponsored Link - Powered by Google.

コメントを残す

メールアドレスが公開されることはありません。 * が付いている欄は必須項目です